OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

camp message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: [OASIS Issue Tracker] (CAMP-176) in `xxx` allow `type` as a synonym for `xxx_type`

     [ https://issues.oasis-open.org/browse/CAMP-176?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gilbert Pilz updated CAMP-176:

    Proposal: https://www.oasis-open.org/apps/org/workgroup/camp/download.php/55251/camp-spec-v1.1-wd49-issue-176-v1.doc

I've posted a proposal that simply renames 'artifact_type', 'requirement_type', and 'characteristic_type' to 'type'. Since each of these nodes is contextualized by its containment in the ArtifactSpecification, RequirementSpecification, and CharacteristicSpecification (respectively) there is no risk of confusion (at least from a parsing perspective).

> in `xxx` allow `type` as a synonym for `xxx_type`
> -------------------------------------------------
>                 Key: CAMP-176
>                 URL: https://issues.oasis-open.org/browse/CAMP-176
>             Project: OASIS Cloud Application Management for Platforms (CAMP) TC
>          Issue Type: Improvement
>          Components: Spec
>            Reporter: Alex Heneveld
> Plans become much easier to read if we allow people to simply refer to a `type` in their artifact/service/requirement definitions.
> Calling them `aritfact_type` and `service_type` and `requirement_type` is just long-winded and redundant in almost all cases.
> I suggest accepting the longer form `xxx_type` for an `xxx` in case there is any ambiguity.

This message was sent by Atlassian JIRA

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]