OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

codelist message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [codelist] genericode element naming: LocationUri versus LocationUrl


I understand the motive, but I think the old name still makes sense. The "Location" part of the name indicates that the value is in the subset of URIs that are URLs.

So the question is "is the proposed change better?". Personally, I don't think so as we have other URIs, and this is just the one that identifies a location. Some of the others might also point to locations. I think mixing the terms "Uri" and "Url" will cause confusion, so I prefer the old name.



> -----Original Message-----
> From: Anthony B. Coates (Miley Watts) [mailto:abcoates@mileywatts.com]
> Sent: 13 August 2007 11:09
> To: Code List Representation TC
> Subject: [codelist] genericode element naming: LocationUri versus
> LocationUrl
> I'm currently editing the genericode Schema to make the public review  
> changes.  However, while doing so, I noticed that one of the 
> element names  
> that I originally chose, "LocationUri", doesn't make a lot of 
> sense, since  
> really this has to be a URL.  I think it should be called 
> "LocationUrl".   
> Would anyone be opposed to this change, or does anyone have any other  
> comments about the suggestion?  Thanks,
> Cheers, Tony.
> -- 
> Anthony B. Coates
> Senior Partner
> Miley Watts LLP
> Experts In Data
> UK: +44 (20) 8816 7700, US: +1 (239) 344 7700
> Mobile/Cell: +44 (79) 0543 9026
> Data standards participant: genericode, ISO 20022 (ISO 15022 XML),  
> http://www.mileywatts.com/

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]