OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

dita message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Incorrect names of 1.2 XSD Modules

There are two issues here:

1. The modules commonElementGrp.xsd and commonElementMod.xsd should be
named commonElementsGrp.xsd and commonElementsMod.xsd (note the added "s")
to match the corresponding DTD modules. This can be handled in 1.3 by
generating both commonElementGrp/Mod.xsd that simply include the
correctly-named commonElementsGrp.xsd and commonElementsGrp.xsd and
provide catalog mappings from the old and new URNs to the correctly-named

2. All of the 1.2 domain modules are misnamed per the letter of the 1.2
spec in that none end with "Mod.xsd", e.g.,

highlightDomain.xsd rather than the required highlightDomainMod.xsd.

The 1.2 spec says:

"Domain modules must consist of a single XSD document named

note the "Mod.xsd" requirement. I can't find any place in the XSD coding
requirements that "Domain" is required to occur in the "modulename" part
of the module. That is clearly an oversight. The corresponding DTD topic

"For domain modules, the file name is the domain name plus Domain plus the
ent extension, e.g. highlightDomain.ent,newAttDomain.ent."

I can't find analogous language in the corresponding XSD topics.

I agree that for XSD (and by extension RELAX NG), the Domain suffix is
sufficient to distinguish domain modules from all other module types and
therefore the "Mod" suffix is redundant, especially since domain modules
in XSD and RELAX NG always consist of a single file (as opposed to DTDs,
which have .mod and .ent files).

So I would be happy to change the language in 1.3 from "must" to "should"
or even more explicitly make both the "Domain.xsd" and "DomainMod.xsd"
forms conforming:

For domain modules, the file name is the domain name plus Domain plus,
optionally, "Mod", e.g.:
highlightDomain.xsd or xmlDomainMod.xsd.



Eliot Kimber, Owner
Contrext, LLC

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]