OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: RE: DOCBOOK-APPS: <procedure> - Getting Extra Line in <step>

For the xsls, this may be related to a (different) bug. As I recall,
this only shows up in FOP. There' s a fix/workaround posted with the bug


See also the thread that ends here:


-----Original Message-----
From:	Andy Jewell
Sent:	Wed 7/24/2002 9:44 AM
To:	Docbook
Subject:	DOCBOOK-APPS: <procedure> - Getting Extra Line in <step>

Hi. . .  I'm having the same problem reported by David Cramer in the
docbook-apps archive
That problem is that in both FO and RTF I get an extra line in each
<step>.  A snippet from his post that is my exact problem, is this:
       <title>Scary Procedure</title>
               I'm on the first step, Johnny.
               I'm on the second step, Johnny.
Generates this:
Scary Procedure


 I'm on the first step, Johnny.


 I'm on the second step, Johnny.
In the above post, the fix was described as adding list item spacing to
the step template.  My fo\lists.xsl (v.1.50.0 - does the same thing,
incidently, in xsl-1.51.1/1.52.2 and dsssl-1.76/1.77) already has
<xsl:template match="step">
  <xsl:variable name="id"><xsl:call-template
    <fo:list-item-label end-indent="label-end()">
      <fo:block id="{$id}" xsl:use-attribute-sets="list.item.spacing">
        <!-- dwc: fix for one step procedures. Use a bullet if there's
no step 2 -->

I saw an item on DPawson's FAQ regarding indexterms and whitespace
issues so I've tried closing up every bit of white space (e.g.,
<step><para>text</para></step) and I still get the same result.

This is my last obstacle for our basic docbook implementation and I'm
afraid because of my limited knowledge, the only solution I'll have is
change the procedures to orderedlists.  Does anyone have any idea of
what could be causing the extra line in these steps?  I'd much rather
use the <procedure> tags but just don't have the experience to know how
to fix this.  Hope you can help!

-- Andy


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC