OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: DOCBOOK-APPS: Docbook, utf8 and generating output formats

I've tried for the past week to find a way to reliably generate pdf, ps, rtf, 
html (and preferably tex, too) from xml docbook - db41xml. The source file is 
encoded in utf-8, and does contain weird characters, like full IPA or 
Tibetan, or Chinese. And I've only had full success with generating html,
and partial success with pdf.

I am wonder whether I've overlooked any options, or whether people have had
success with tools I've failed with. I've tried the following:

Using Jade

Jade complains about things like:
 jade:/home/boud/prj/denden/segtable.dbx:30:30:E: non SGML character number 
128, which is silly, because I'm not using SGML, but XML.
cannot generate system identifier for public text "ISO 8879:1986//ENTITIES 
Added Latin 1//EN"
  but does produce some output.
	-> html: some success, but lots of 
	-> tex: the utf-8 characters are included in the tex source, but tex
		appear to be unable to use them. I've tried adding things like
		unicode.tex, but didn't have any success, probably because those
		tex hacks are intended for Latex, not plain tex.
	-> rtf: By default, the unicode characters are mangled. I can replace
		all unicode characters by hex codes, and then replace the hex codes
		in the resulting rtf file by unicode characters. But that's
		a real hack.
	-> pdf: All unicode characters come out mangled
	-> ps: ditto, of course.

Using docbook xsl
	This works pretty well.
	fop: Works, but only with simple documents that don't include complex 
	jfor: Doesn't work because latest docbook xsl uses % as units for tables,
		and jfor doesn't know about that.
	passivetex: Can't get this installed -- even the default installation that
		comes with SuSE has trouble generatign pdf from the test
		files included with passivetex.

(I use SuSE 8.0, with the Jade that's included with SuSE. All other
components are latest stable versions. Jade couldn't find xml.dcl in
the default install, but I fixed that.)

Boudewijn Rempt | http://www.valdyas.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC