OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Problems using PassiveTeX/JadeTeX for equations


recently I was proud that I got Saxon running to transform my DocBook 
documents into HTML and PDF. All worked so far, using DocBook-XML-4.3, 
  the 1.65.1 XSL-stylesheets and FOP (I'm working with Windows, but I 
also have Linux installed).

Then I discovered that FOP won't translate equations very well (if at 
all?), so I tried to change my FO-processor from FOP to PassiveTeX 
(TeXLive 7 distribution).

I soon discovered that PassiveTeX doesn't work. It is able to produce 
a title page and one blank page, but not more. (I only have one single 
chapter with one paragraph included - and some meta info for the book. 
I don't even use equations.) During processing it complains a lot 
about all sorts of fo-constructs it doesn't seem to understand. I used 
passivetex.extensions="1", but it didn't help.

On the mailing list I read that it would only work with the 1.61.3 
XSL-stylesheets. So I tried them, but PassiveTeX produces the same 

Almost desperate, I looked at DBTeXMath and the SGML version of 
DocBook. So I installed OpenJade 1.3.2 and the DSSSL-stylesheets 
(1.78). It only seems to run with DocBook-XML 4.2 though.

Anyhow, this solution almost works for me now, that is, I can see 
equations in my PDF and HTML output (!).

The problem is that OpenJade still complains about the equations when 
processing the document. In the output document (PDF and HTML), a ">" 
bracket appears immediately behind all my equations.

The exact message OpenJade produces (Windows) is:

"procedure does not have "INLINEEQUATION" keyword argument".

The Linux version produces (it's not the exact message, but similar):

"inlineequation ... no open tag"

The markup looks like the following:

<para> ...
   <graphic fileref="figures/nsquare.png"/>

Without the equation, everything runs fine. I also copied some 
equation-markup from the DBTeXMath sample into my document - same 
result. Also the same result when I'm processing the DBTexMath sample 

What's wrong here?

Do I have to use another version of the DSSSL-stylesheets perhaps?

I really would like to use OpenJade, since it is much faster than XSL 
processing with Saxon and so far produced the best results with regard 
to equations.

Did anyone have a comparable problem with OpenJade/DSSSL perhaps?

With regard to future developments, does it make sense at all to go 
for the SGML version of DocBook?

Am I right that version 4.3 of DocBook and the 1.65.1 stylesheets 
don't work together with PassiveTeX? What versions would I have to use 
  if I wanted to use PassiveTeX?

Thanks in advance for any replies,


PS: At the moment I'm using DB2Latex, but I don't like it very much, 
to be honest. Moreover, it doesn't produce HTML output with equations, 
which I would like to do.

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]