OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Problem: fop && docbook-xsl on debian sarge

Matthias  Mosimann <matthias_mosimann@gmx.net> writes:

> I try to figure out a problem on debian sarge r3.1. Maybe someone could help
> me out here.
> I did on sarge:
> apt-get install fop && fop-doc && docbook-xsl
> fop -xsl /usr/share/xml/docbook/stylesheet/nwalsh/fo/docbook.xsl -xml
> docbook-test-02.xml -pdf docbook-test-02.pdf

That should work, but you might want to try it this way instead:

  xsltproc --stringparam fop.extensions 1 \
    /usr/share/xml/docbook/stylesheet/nwalsh/fo/docbook.xsl \
    docbook-test-02.xml > docbook-test-02.fo

Then this:

  fop docbook-test-02.fo docbook-test-02.pdf

> Shows me always the same error. A PDF was generated but is useless (PDF
> Viewer can't open it).

Which PDF viewers did you try?

> [...]
> [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
> [INFO] base directory: file:/home/matmos/
> [INFO] FOP 0.20.5
> [INFO] Using org.apache.xerces.parsers.SAXParser as SAX2 Parser
> [INFO] building formatting object tree
> [INFO] setting up fonts
> [ERROR] property - "background-position-horizontal" is not implemented yet.
> [ERROR] property - "background-position-vertical" is not implemented yet.
> - until here. Now fop hangs (do nothing for serveral minutes).

That "ERROR" message does not really indicate a fatal error. FOP
will emit that message every time you run it with a DocBook doc.
But it will still generate a usable PDF in spite of it.

How much memory do you have on your machine? Perhaps FOP is
running out of memory.

> (I tried some diffrent Version of the dtd and diffrent verstion of the xsl
> stylesheet but I crash allways into the same error). I think that's a very
> simple problem here. (Am I to impatient?!)

I just tried on a Debian system with version 1:0.20.5-5 of the
"fop" package, and I got a usable PDF (could open in xpdf,
acroread, evince). You can check it here:


If you try calling xsltproc and fop as I've described above, and
it still doesn't work, I'm not sure what else to suggest. You
might try running FOP against some other .fo files and see if it
hangs on those. If you have fop-doc installed, you can find a
bunch of (gzipped) .fo files in:


Hope that helps,


Michael Smith


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]