OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Trouble with tables, xsltproc

Hi all,

I'm having an awfully hard time trying to put a table in a document. 

It's in a <book>, inside a <appendix> and a <sect1> in that appendix, in
between a <para>...</para> and a <itemizedlist>...</itemizedlist>... I
moved it to a chapter in a <sect1> and between a <para> and the next...
I even tried warpping it within a <para> tag pair itself.  

In all cases the XSLT processor (xsltproc) fails almost immediately
while starting to write the fo file with this error:

XPath error : Invalid context position
xmlXPathCompiledEval: evaluation failed

The error seems to suggest the table is existing within elements that
it's not allowed to be within. But if I run xmllint on my xml file there
seem to be no validity errors about tables.

Even more curiously, the indentical table works fine inside a simpler
document where I tested them out, inside a <article>.  

Any clues?



Alan C. Oehler
Sr. Technical Writer
XenSource, Inc.
Phone: 650.798.5900 x 240

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]