OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Using additional Fonts with FOP 0.93 failing

I previously have used the Windows palatino font with FOP 0.25, 
successfully.  I'm having trouble getting this to work in 0.93. 

Following the instructions, I regenerated the font metric information 
for 0.93, specifying the -enc ansi options in order to be able to embed 
the font.  That seemed to generate OK, except for one warning message.  
Here's the messaged from that:

     [java] TTF Reader for Apache FOP 0.93
     [java] Parsing font...
     [java] Reading c:\Windows\fonts\pala.ttf...
     [java] Number of glyphs in font: 1328
     [java] Ascender and descender together are larger than the em box. 
This could lead to a wrong baseline placement in Apache FOP.
     [java] 8 cmap tables
     [java] CMAP format: 4
     [java] Creating xml font file...
     [java] Creating WinAnsi encoded metrics...
     [java] Writing xml font file 
     [java] This font contains no embedding license restrictions.
     [java] XML font metrics file successfully created.

I then modified my fontconfig.xml file to reference the newly generated 
font metric xml files for the plain, bold, italic, and bold-italic 
versions of this.  I also noticed that <font metrics-file= ... of FOP 
0.25 is now <font url=...  so I changed that too.

I know my fontconfig.xml is being read (using the -c option of FOP), 
because if I mess with the syntax of this file, I get a syntax error 
reported from FOP.  However, I think it's not reading the generated font 
metrics files, because I can put invalid syntax into those, or even 
delete them, with no change in FOP behavior.

Here's the start of the fontconfig.xml file:, showing the "relative" 
form used for the url (I tried, relative, with/without <font-base>

    <font metrics-url="palatino.xml"
      <font-triplet name="Palatino" style="normal" weight="normal"/>

+ 3 other <font...> tags for the bold/italic/bold-italic versions

The behavior I'm getting is that is always logs:

     [java] [WARN] FontInfo - Font 'Palatino,normal,400' not found. 
Substituting with 'any,normal,400'.
     [java] [WARN] FontInfo - Font 'Symbol,normal,700' not found. 
Substituting with 'Symbol,normal,400'.

And, it seems to format the document OK, except every character is 
replaced with a "#" character.

I've tried using all kinds of formats for the url in fontconfig.xml for 
to point to the metrics file, including
file:///C:/.... (an absolute path to the metrics file, ending in the 

I'm a bit puzzled about Symbol,normal, 700 not being found as well.

Any hints about what I'm doing wrorng are appreciated.

-Marshall Schor

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]