OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Re: Empty index page in chunk output from1.73.0 [was: Going to DocBook 1.73]

Marie Sauvage - EBM WebSourcing <marie.sauvage@ebmwebsourcing.com>, 2007-07-24 11:10 +0200:

>    I've made several tests and always get the same problem. Here are in a zip
>    the results of my transformation with 1.72 and 1.73.
>    My chunk.xsl is :
>      <?xml version="1.0"?>
>      <xsl:stylesheet xmlns:xsl=[1]"http://www.w3.org/1999/XSL/Transform";
>                      version='1.0'>
>        <!--xsl:import href="../docbook-xsl-1.72.0/html/chunk.xsl" /-->
>        <xsl:import href="../docbook-xsl-ns-1.73.0/html/chunk.xsl" />

So I notice that you're importing the 1.73.0 docbook-xsl-ns
stylesheet. If you try it with the docbook-xsl (non-namespaced)
stylesheet, do you get the same result?

Are there any XPath expressions in your customization layer, and
if so, are they all namespace-aware?

>    the only thing I've changed between the two generations is the import of
>    the chunk.xsl, I've commented the import of my other config file to be
>    sure it doesn't interfer... even when I suppress everything except the
>    import, I still have an empty index...
>    I make the transform with an ant call to xslt (v 1.1.15), here is my task
>    (simplified, in my build file everything is variables) :
>        <target name="transformWithXalan">
>          <exec executable="xmllint" failonerror="true">
>            <arg line="--output tmpfile" />
>            <arg line="--xinclude" />
>            <arg value="src/doc/MyTestBook.xml" />
>          </exec>
>          <xslt basedir="${basedir}" style="src/stylesheets/chunk.xsl"
>      in="tmpfile" out="target/chunk/index.xml" extension=".html">
>            <xmlcatalog>
>              <dtd publicId="-//OASIS//DTD DocBook XML V4.4//EN"
>      location="/usr/share/xml/docbook/schema/dtd/4.4/docbookx.dtd" />
>            </xmlcatalog>
>          </xslt>
>          <delete file="tmpfile">
>          </delete>
>        </target>
>    I've also tested with DocBook 5.0b5 DTD and get the same.
>    I had a look at the tmpfile wich is used by xslt and it's exactly the same
>    as the original, as there is no xi:include to transform...
>    what xslt engine are you using ?

I tried it with both xsltproc and saxon from the command line and
got the output I would expect (the zip file I posted previously).
If you have access to xsltproc and saxon, please try testing with
those. If those work for you as expected, then it seems there must
be some problem in your Ant task.



[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]