OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Page title formatting error with 1.69.1 stylesheets

I'm using the DocBook style sheets to format a user manual for MySQL++. 

For the previous release of MySQL++, I prepared the manual on a 
different machine which came with v1.65.1 of the style sheets, and it 
worked correctly.  Since moving to a newer machine with a newer OS and 
thus newer DocBook style sheets (v1.69.1), the title at the top of each 
page now has line breaks that didn't appear before.

You can view the last release's user manual here, for comparison:


To reformat the current manual yourself, grab a copy of the manual 
sources with:

	svn co http://svn.gna.org/svn/mysqlpp/trunk/doc/userman

Then cd into 'userman', check the FOP path at the top of Makefile (or 
uncomment one of the other processors' lines to switch to that one), and 
say 'make pdf'.  Just ignore the XInclude warnings.

The title is supposed to be "MySQL++ User Manual", centered at the top 
of the page.  With FOP, what I actually get is something like this:


This runs down the left side of the page, overlapping whatever's already 
there.  There are underbars under each line of this.

It looks like FOP is trying to hyphenate the text, but a) why would it 
need to hyphenate it; and b) is it even allowed, given that I've turned 
off hyphenation?

The problem's not with FOP specifically.  I also tried the demo versions 
of the RenderX and Antenna House formatters, and got two different 
results.  One of them (don't remember which) formatted this "correctly" 
to my eye, but the other did something similar, except that it was a 
stack of single characters instead of hyphenated fragments:



Is this a bug in the DocBook stylesheets that has since been fixed?  I 
tried looking at the ChangeLog, but there's just too much to wade 
through.  If it's a known bug, is there a patch I can apply to fix it, 
rather than upgrade to a newer version?

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]