OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] syntax highlighting doesn't work, nor throws errors.

Hash: RIPEMD160

Mike wrote:

>> But that's about the last idea... for when I use your command-line in
>> the test directory (with adjusted paths), I do get the highlights.
>> So, even if you think I am a moron for even suggesting it, could you
>> check your stylesheet for any formatting on the <b>?
> No no, at this point I've run out of ideas anyway! I appreciate the attempt,
> I only just added the docbook.css recently. It's the bsd docbook, first 
> on the list here:
> http://wiki.docbook.org/topic/DocBookCssStylesheets
> Before that I had no css, and still no highlighting.  Does the syntax 
> highlighting need a specific docbook? I was thinking it might, but when 
> I view source on the html, there's no, like <span> tags in the code or 
> anything anyway.  And of course, I still get that error when I do the 
> tansform.
> There's probably something else in your build.xml that I need to add to 
> my line command... some flag or something...

Alright... let's see... I'll try to summarize what I have in terms of
settings... maybe you can spot what's missing:

The Java call to transform from Docbook to HTML:

java \
- -classpath [Path to saxon.jar]:[Path to xslthl.jar]:[Path to
saxon65.jar] \
- -Dxslthl.config="file://[Path to xslthl-config.xml]" \
com.icl.saxon.StyleSheet [Path to input.xml] [Path to stylesheet]

In the customization stylesheet:

<xsl:import href="[Path to chunk.xsl]"/>

<xsl:import href="[Path to highlighting/common.xsl]"/>
<xsl:import href="[Path to html/highlight.xsl]"/>

<xsl:param name="base.dir" select="'[Path to your basedir]"/>

<xsl:param name="highlight.source" select="1"/>

And, as a last resort... The MD5SUM of the xslthl-config.xml

c64c7a25b6c62422f6b4653f4f6174c2  xslthl-config.xml

In case you haven't checked that your xslthl library isn't broken somehow...

And that's it.

All I can suggest now is that you copy some of your data into the test I
sent, configure the paths in the build.xml and try to find out whether
the ANT build does produce the correct output... for if it does then we
know that it's a problem with your normal setup. Otherwise, all bets are
off and it could be broken JARs or something similar...


- --
All the really good ideas I ever had came to me while I was milking a cow.
		-- Grant Wood
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]