OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] syntax highlighting doesn't work, nor throws errors.

Hash: RIPEMD160

Mike wrote:

> Thanks very much man, I hope you're asleep now, but here's my 
> response if you come back tomorrow.

*chuckles* Nah... no such luck... ;-)

> First I got:
> $ ./build.sh Error at xsl:import on line 5 of 
> file:/www/notlive/HighlightTest/./styles/customization.html.xsl: 
> Failure reading 
> file:/home/jpm/Development/XML/DocBook/docbook-xsl/html/chunk.xsl: no
>  more input Transformation failed: Failed to compile stylesheet. 1 
> error detected.
> That's because your customization.html.xsl still had your paths in 
> it. No problem, I switched it to my xsl instead and made my paths 
> absolute.


> And then:
> ./build.sh Note: namesp. cut : stripped namespace before processing 
> Code Highlighting test Note: namesp. cut : processing stripped 
> document                   Code Highlighting test Loading Xslthl 
> configuration from 
> file:///www/notlive/docbook/xslthldamnit/highlighters/xslthl-config.xml...
>  XSLT Highlighter: Cannot read xslthl-config.xml, no custom 
> highlighters will be available. Writing 
> /www/mfsite/docbook/templatedocs/index.html for article
> and still, no highlighting.
> I am cursed.

*chuckles* I sincerely hope not.

So we're back at the very same error that we have been fighting for a
while now. Interesting.
You mentioned that the file
/www/notlive/docbook/xslthldamnit/highlighters/xslthl-config.xml is
readable, right? So it can't be a permission problem.

Hmmmm... I re-checked... you wrote:

> -Dxslthl.config="file:///www/notlive/docbook/xslthldamnit/highlighters/xslthl-config.xml"
> I also tried giving it the path to the xslthl-config.xml file that
> comes with the docbook xsl:
> -Dxslthl.config="file:///www/notlive/docbook/docbook-xsl-1.74.3-pre/highlighting/xslthl-config.xml"
> Which is also a valid path, and I can also cut and paste into firefox
> (including the "file://" part) and see the file.  Still get the error
> message and no highlighting.

At the moment, we're using the first file. Did you check its readability
as well (just crossing my t's here)?


P.S. Yes, I am off for today now. ;-)

- --
martin@bdsi.com (no longer valid - where are you now, Martin?)
		-- from /usr/src/linux/drivers/cdrom/mcd.c
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]