OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] running header breaks into 2 lines!

Hi Robert,
The header.column.width param should do the trick.  If it has no effect, then 
something must be overriding it.

You might try adding this fake param to your customization layer.  Its only effect is 
to send a message to standard error about that the header.column.widths param value is 
that the stylesheet is seeing.

<xsl:param name="foo">
  <xsl:message>header column widths is <xsl:value-of 

If you find that the param is not what you expect, then something is overriding the 
value.  If the param is what you expect, then something is going on with the header 
table, which is defined in the template named 'header.table' in fo/pagesetup.xsl.

Bob Stayton
Sagehill Enterprises

----- Original Message ----- 
From: "Robert Nagle" <idiotprogrammer@gmail.com>
To: <docbook-apps@lists.oasis-open.org>
Sent: Monday, September 06, 2010 7:11 AM
Subject: [docbook-apps] running header breaks into 2 lines!

> For some reason the headers on my PDF are way too narrow for headings.
>  It cannot have more than 30 characters and breaks into 2 lines if it
> exceeds that.
> The page size is not that small. 23.4 cm x 15.6 cm, and inner/outer
> margins are 1.91cm and 1.27 cm respectively.
> I tried increasing the column width
>    <xsl:param name="header.column.width">1 2 1 </xsl:param>
> but I found that regardless of what values I enter  entered here,  it
> still cannot handle more than 30 characters. The values mentioned here
> don't seem to have any effect  (I even tried 1 4 1, 0 1 0, etc).
> I've tried this in XEP and Apache FOP with the same result.
> The only thing that did seem to work is to reduce the font size to 8
> point (which frankly looks absurd).
>    <xsl:attribute-set name="header.content.properties">
>        <xsl:attribute name="font-family">Gentium</xsl:attribute>
>        <xsl:attribute name="font-size">8pt</xsl:attribute>
>    </xsl:attribute-set>
> Does anyone have ideas about what might cause this to happen? Aside
> from what I have mentioned here, there are no other relevant
> customizations which might affect this.
> Does anyone have other  ideas about what might be shrinking my header width?
> -- 
> Robert Nagle
> htpt://www.robertnagle.info
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: docbook-apps-unsubscribe@lists.oasis-open.org
> For additional commands, e-mail: docbook-apps-help@lists.oasis-open.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]