OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [docbook-apps] Docbook Webhelp: saxparser problem

Hi David,
What version of ant are you using? I've just discovered that the webhelp build.xml fails with ant 1.8.1 (and I know it works with 1.6.5 to 1.8.0), however it fails at a different point and with a different error than you're seeing. 


> -----Original Message-----
> From: David Priest [mailto:docs@davidpriest.ca]
> Sent: Wednesday, November 17, 2010 2:27 PM
> To: docbook-apps@lists.oasis-open.org
> Subject: [docbook-apps] Docbook Webhelp: saxparser problem
> I've been trying to implement in Ant the indexer part of the Docbook
> Webhelp transformation.  I have this error:
> [major snippage]
>       [xslt] JAXP: find factoryId =javax.xml.parsers.SAXParserFactory
>       [xslt] JAXP: loaded from fallback value:
> com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl
>       [xslt] JAXP: created new instance of class
> com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl using
> ClassLoader: null
>       [echo] Indexing html files in
> /Users/davidp/dev/release-docs/Admin_Guide-webhelp/content
> [indexertask] JAXP: find factoryId =javax.xml.parsers.SAXParserFactory
> [indexertask] JAXP: found system property,
> value=org.apache.xerces.jaxp.SAXParserFactoryImpl
> /Users/davidp/dev/davidpriest/ant/publish.xml:420:
> javax.xml.parsers.FactoryConfigurationError: Provider
> org.apache.xerces.jaxp.SAXParserFactoryImpl not found
>      at
> javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:13
> 4)
>      at
> com.nexwave.nquindexer.SaxDocFileParser.parseDocument(SaxDocFileParser.
> java:67)
> [snip]
> There are a nigh-infinite number of debug messages where JAXP loads
> from
> fallback.  And *immediately* before the indexer is fired-up, JAXP does
> exactly the same thing as had worked for every other step of the
> transformation process.
> But then, whack, nquindexer craps out when it tries to execute its
> indexer task.
> I have tried to point it directly at xerces by including it in the
> indexer's classpath.  I've tried eliminating classes that I think might
> contain a sax parser of their own (but, then, if those were
> interfering,
> I'd expect the other debug messages to indicate that).
> I should note that my Ant indexertask is copied directly from the
> script
> provided with Docbook's Webhelp.
> Does anyone have any hints on how I can resolve this issue?
> Thanks in advance
>    david
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: docbook-apps-unsubscribe@lists.oasis-open.org
> For additional commands, e-mail: docbook-apps-help@lists.oasis-open.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]