OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] hours to process chunks

On Tue, Sep 13, 2011 at 7:37 AM, Jirka Kosek <jirka@kosek.cz> wrote:
> On 6.9.2011 20:05, Tim Arnold wrote:
>> I also tried saxon9.30 and of course I cannot do chunking with it and
>> the XSLT1.0 stylesheets, but with no chunking it finished in 1 minute
>> 23 seconds.
> Actually you can do chunking with Saxon 9, see
> http://lists.oasis-open.org/archives/docbook-apps/201103/msg00123.html
> Because there were some troubles to make this code work in all XSLT 1.0
> based processors it never made up into main trunk. But it might work in
> your case. If you succeed, please let us know what performance gain was
> there and if you have faced some problems.
>                                Jirka
Hi Jirka,
Thanks for that information. I must be doing something wrong:

I copied the stylesheet from that thread, removed the semicolons from
the header element so it looks like this:
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform";
                exclude-result-prefixes="doc ch saxon lxslt redirect exsl"
                extension-element-prefixes="saxon redirect lxslt exsl">

the semicolons seemed to be errors when I tried running saxon9.
I then replaced the original 'html/chunker.xsl' with the resulting file.

I ran the following command:

java -jar saxon9he.jar qcug.xml \
/AppDocs/xml/docbook/xsl-1.76.1/html/chunk.xsl \
current.docid=qcug \

and got this result:

Warning: at xsl:stylesheet on line 5 column 50 of chunk.xsl:
  Running an XSLT 1 stylesheet with an XSLT 2 processor
Warning: Stylesheet module
file:/AppDocs/xml/docbook/xsl-1.76.1/common/utility.xsl is included or
  imported more than once. This is permitted, but may lead to errors
or unexpected behavior
Error at xsl:apply-templates on line 389 column 90 of chunker.xsl:
  XPST0017 XPath syntax error at char 0 on line 389 near
    Cannot find a matching 1-argument function named
  There is no Saxon extension function with the local name node-set
Failed to compile stylesheet. 1 error detected.

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]