OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Image location

On 30 Sep, 2011,at 11:29 AM, Lars Vogel <lars.vogel@googlemail.com> wrote:


I'm trying to create PDF from my Docbook output via the corresponding stylesheets but FOP cannot find the image. I read Bobs description and I believe the path of the image is correctly setup.



The generated FO source look like the following:

<fo:block id="d0e101"><fo:external-graphic src="" width="auto" height="auto" content-width="auto" content-height="auto"/></fo:block>

and files are in the following structure:



I also tried:



If I run the FOP transformation I receive:

 [fop] Image not found. URI: content/images/DojoFolder10.gif. (See position 60:101)

Any advice would I'm doing wrong?

Although we switched to XEP a while back, I did start off using FOP. I can't remember exactly why my old FOP Makefiles did this, but it *looks* like they were trying hard to get working references to images. So what I used to do in my old Makefiles was to change to the directory containing my book.xml, and then run the xsltproc and fop from there. I also set img.src.path to `pwd`, which may have been overly paranoid...

If you can (given the other fun you seem to be having with FOP), I would recommend getting the free personal edition of XEP and see how that works. We felt that XEP was a much better processor than FOP, and it was worth our while spending the relatively small amount getting the non-free version.


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]