OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Error when trying to cross reference external documents

Yes, that is very helpful. It indicates that the file is being found, but the problem is in parsing it. The problem comes from that "feature" of Xalan that converts certain characters to entity references. In the DocBook XSL gentext files, there are no named character entities, so Xalan is taking utf-8 characters and converting them to named character entities like “ when it generates the target.db file. That mail thread mentions how to turn off that Xalan feature, so that the utf-8 characters are not converted, which would allow the file to be parsed without declaring the character entities.

Or you could declare the character entities in the olinkdb.xml file. This can be done as described here for DocBook 5 documents:


You would need to download the DocBook 4 DTD which has definitions of those entities. The doc describes how they are included in olinkdb.xml. Then when the target.db files are read, those character entities are declared and the file should parse. If it is all working, you should be able to validate olinkdb.xml, and then it will open for olinks.

Bob Stayton
Sagehill Enterprises

From: "Trasca Virgil" <virgil_trasca@yahoo.com>
Sent: Thursday, February 28, 2013 3:44 AM
To: <docbook-apps@lists.oasis-open.org>
Subject: [docbook-apps] Error when trying to cross reference external documents

Hi Bob,

I did the change and there is no difference. Is failing in the same place and with the same error.

Suspecting that it might be a problem with one of xalan/ant and maybe eclipse I updated all to the latest version. Still no luck and is still failing.

However I managed to trace some more specific error messages. Please see the attached screenshot.

I also found a thread which might be related but I am not sure - https://lists.oasis-open.org/archives/docbook-apps/200808/msg00065.html

Is this information more helpful?

Thanks again,


I think the problem is with the way the system entities are expressed for the target data files:

<!ENTITY userguidetargets SYSTEM "D:/Projects/6.1.2-18Feb/appli

Those need to use file: syntax.  For Windows, that would look like this:

<!ENTITY userguidetargets SYSTEM "file:///D:/Projects/6.1.2-18Feb/applications/documentation/target/package/docs/userguide/target.db">"

To unsubscribe, e-mail: docbook-apps-unsubscribe@lists.oasis-open.org
For additional commands, e-mail: docbook-apps-help@lists.oasis-open.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]