OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: AW: [docbook-apps] Problems with bibliography

Hi Niels, sure about the xml Namespace at your id? Try once without it. In my case I never use the xml:id notation with my bibliorefs, but if I did I ran into the same conflict as you did: id was not found.


-----Ursprüngliche Nachricht-----
Von: Niels Müller [mailto:neinalways@gmail.com] 
Gesendet: Mittwoch, 8. April 2015 10:52
An: docbook-apps@lists.oasis-open.org
Betreff: Re: [docbook-apps] Problems with bibliography

Thanks for replying Bob.

Extract from errlogxslt:
     230 Resolve: sysID file:///foo/biblio.xml
     231 Resolve URI file:///foo/biblio.xml
     232 Found URI match file:///foo/biblio.xml
     233 Resolve: sysID file:///basics/uvmat_entities.ent
     234 Resolve URI file:///basics/uvmat_entities.ent
     235 Using rewriting rule file:///basics/
     236 Resolve: sysID file:/home/nml/.docbook/xhtml-lat1.ent
     237 Resolve URI file:/home/nml/.docbook/xhtml-lat1.ent
     238 Resolve: sysID file:/home/nml/.docbook/xhtml-symbol.ent
     239 Resolve URI file:/home/nml/.docbook/xhtml-symbol.ent
     240 Resolve: sysID file:/home/nml/.docbook/xhtml-special.ent
     241 Resolve URI file:/home/nml/.docbook/xhtml-special.ent
     242 Resolve: sysID file:/home/nml/.docbook/hsizes.ent
     243 Resolve URI file:/home/nml/.docbook/hsizes.ent
     244 No bibliography entry: Doy10 found in file:///foo/biblio.xml

I interpret lines 230 through 232 such that my bibliography file has 
been found.
Line 244 says Doy10 not found, but it most certainly exists in the
bibliography file

   <bibliomixed xml:id="Doy10">
         <surname>Doyle</surname>, <firstname>Matt</firstname>
     <citetitle>Beginning PHP 5.3</citetitle>.

The only validation errors I have are some dual id's which never had 
this side effect. They just have to go before I convert to pdf. But here
I transform to html.

I have run out of ideas.

Niels Muller Larsen, MSc
Programmer, Assoc Professor

The famous politician was trying to save both his faces.

On 04/07/15 01:11, Bob Stayton wrote:
> Hi Niels,
> There are two possible sources for this error:
> a. It cannot open the bibliography database file.
> b. It cannot match the id in the file.
> If you look in errlogxslt, does it have an error message about not being
> able to open the bibliography file?  That will determine whether a or b
> is the cause.
> Bob Stayton
> Sagehill Enterprises
> bobs@sagehill.net
> On 4/6/2015 5:32 AM, Niels Müller wrote:
>> Hi there
>> I have for year created my course materials with docbook 5, with no or
>> very few problems at all.
>> Recently I reinstalled my laptop with a new Linux, Arch Linux, and after
>> that my generated html pages from the docbook xml documents
>> started displaying:
>> Error: no bibliography entry: Col11 found in
>> file:////home/nml/.docbook/biblio.xml
>> and similar for all bibliography entries.
>> The bibliography is built according to
>> http://docbook.sourceforge.net/release/xsl/current/doc/fo/bibliography.collection.html
>> and worked splendidly until the reinstallation.
>> I searched and the only thing I found was something that indicated I had
>> a similar problem 4 years ago. But the threads do not give away the
>> solution, and I have no recollection about the solution.
>> I have tried a verbose output from xsltproc but it reveals nothing more
>> than the above. The biblio.xml file has the proper url, my browser
>> displays it, and it does contain the xml:id's that I refer to.
>> I use make and the makefile:
>> html:
>>                  rm -rf site
>>                  mkdir site
>>                  xmllint --xinclude \
>>                                  module.xml > /tmp/docbresolved.xml \
>>                                  2>./errloglint
>>                  xsltproc \
>>                                  --output site/ \
>>                                  docbook.xsl \
>>                                  /tmp/docbresolved.xml \
>>                                  2>./errlogxslt && \
>>                  tar czf site.tgz site/*
>>                  echo "site.tgz ready for deployment"
>> Does anyone have a clue or intuition?

To unsubscribe, e-mail: docbook-apps-unsubscribe@lists.oasis-open.org
For additional commands, e-mail: docbook-apps-help@lists.oasis-open.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]