OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: AW: [docbook-apps] Bibliography in DocBook5, continued problems

Bob I am speechless. Spot on.
Downloaded the ns stylesheets, they were not in the Arch Linux stylesheet package, and it worked right away with the adjustments in my customization files.

If you're ever in Aarhus, Denmark, the Anchor Steam is on me, and likewise if I am ever in Santa Cruz.

Thank you, wizard.

Niels Muller Larsen, MSc
Programmer, Assoc Professor

"Trust me.  I know what I'm doing."
-- Sledge Hammer

On 05/06/15 17:46, Bob Stayton wrote:
I suspect this problem is arising from using the non-namespaced
stylesheets to process Docbook5 files.  You mentioned that you are
processing DocBook 5 files, but your stylesheet imports


Since there is no "ns" in the directory name, I suspect but cannot
confirm that this is the non-namespaced version.

When the non-namespaced stylesheet is applied to a namespaced DocBook 5
file, it must first strip the namespace from all the elements (and you
should get a message to that effect in the error log).  But I suspect it
isn't converting the imported biblio file.

If this is the case, then switching to the namespaced stylesheets should
fix it.

Bob Stayton
Sagehill Enterprises

On 5/6/2015 5:37 AM, Niels Müller wrote:
Thanks for trying (again) Ben.
When I miss the proper filename for the bibliography file, I get a
warning in the xlstlog file. I do NOT get this warning when I hit the
right name.
This fact combined with the fact that the browser renders the
bibliography file as a tree structure when I take the url from the error
message, and ask the browser to display it, tells me that the error must
be somewhere else.

Niels Muller Larsen, MSc
Programmer, Assoc Professor

Portability should be the default.
              -- Larry Wall in <199711072201.OAA01123@wall.org>

On 05/06/15 10:13, Kallauch, Benjamin (EEIN) wrote:
Hi Niels,

Despite using a totally different software setup, I made also some
tests. There is maybe one hint: If I was renaming the referenced
bibliography file (so the system could not find it anymore), I got the
same error message:

file:///foo/docbook-xsl-1.78.1/fo/biblio.xsl; Zeilennummer234;
Spaltennummer24; No bibliography entry: Doy10 found in

Even if I have no solution for you, I think it is a kind of URI lookup
Maybe this hint is partly helpful for you.


-----Ursprüngliche Nachricht-----
Von: Niels Müller [mailto:neinalways@gmail.com]
Gesendet: Dienstag, 5. Mai 2015 20:35
An: docbook-apps@lists.oasis-open.org
Betreff: [docbook-apps] Bibliography in DocBook5, continued problems

A month ago I tried airing my bilbiography problem here, but none of the
few answers gave me *the* hint to a solution. Let me try again:

I create course materials from several docbook.xml files with a
biliography at the end. My books are in a bibliography file and
referenced in the material through a bibliography file with empty
elements in it. Used to work. Now it doesn't.
I have played with various ways of doing the ref to the actual file.
My customization has:


A fragment of the document bilbiography file:

      <bibliomixed id="Xue14"/>
      <bibliomixed id="yan09"/>
      <bibliomixed id="DKnuth86">Donald E. Knuth. <citetitle>Computers
Typesetting: Volume B, TeX: The Program</citetitle>. Addison-Wesley,
1986.  ISBN 0-201-13437-3.

The bibliography file with all the books has (fragment)

    <bibliomixed id="Xue14">
          <surname>Xue</surname>, <firstname>Qiang</firstname>
      </author>, et al.
      <citetitle>The Definitive Guide to Yii 2.0</citetitle>.
      <publishername>Yii Software LLC</publishername>,

The generated output has (fragment)

[Xue14] Error: no bibliography entry: Xue14 found in

[yan09] Error: no bibliography entry: yan09 found in

[DKnuth86] Donald E. Knuth. Computers and Typesetting: Volume B, TeX:
The Program. Addison-Wesley, 1986. ISBN 0-201-13437-3.

If I take the file statement from file:///home/nml/.docbook/biblio.xml
into my browser it displays the tree structure of the file, so the file
does exist :)

My makefile:

                  rm -rf site
                  mkdir site
                  xmllint --noent --xinclude \
                                  module.xml > /tmp/docbresolved.xml \
                  xsltproc \
                                  --output site/ \
                                  docbook.xsl \
                                  /tmp/docbresolved.xml \
                                  2>./errlogxslt && \
                  tar czf site.tgz site/*
                  echo "site.tgz ready for deployment"

My software

nml1 webdev  $ xmllint --version
xmllint: using libxml version 20902
     compiled with: Threads Tree Output Push Reader Patterns Writer
FTP HTTP DTDValid HTML Legacy C14N Catalog XPath XPointer XInclude Iconv
ISO8859X Unicode Regexps Automata Expr Schemas Schematron Modules Debug
Zlib Lzma
nml1 webdev  $
nml1 webdev  $
nml1 webdev  $ xsltproc --version
Using libxml 20902, libxslt 10128 and libexslt 817
xsltproc was compiled against libxml 20901, libxslt 10128 and libexslt
libxslt 10128 was compiled against libxml 20901
libexslt 817 was compiled against libxml 20901
nml1 webdev  $

The stylesheets


Everything works beautifully except the bib.
It's driving me crazy. please help.

To unsubscribe, e-mail: docbook-apps-unsubscribe@lists.oasis-open.org
For additional commands, e-mail: docbook-apps-help@lists.oasis-open.org

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]