OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [docbook-apps] Odd Characters in UTF-8, Docbook 5.1

I just wanted to add some information from reading build logs for the document. It turns out the error shows up under "fop" because the particular font does not support this character (I'm surprised Times-Roman does not have this by default since just about every application on the system has the character):
WARNING: Glyph "├" (0x251c, SF080000) not available in font "Times-Roman".
The trouble here is I now want to change this for the system as a whole, not just on the document (I want to avoid any project using Times-Roman). I am curious if there is some simple way under Linux to find out which fonts fop has available, and how to change the default font family for all Docbook publishing via a system-wide setting? I've found many documents on modifying Docbook behavior within source code, but not much seems to exist on system-wide Docbook configuration from a system administrator's point of view...if anyone has a URL for information on specifics of tuning Docbook defaults under Linux I'd be very happy!
----- Original Message -----
From: stimits@comcast.net
To: docbook-apps@lists.oasis-open.org
Sent: Tue, 31 Jan 2017 23:20:24 -0000 (UTC)
Subject: [docbook-apps] Odd Characters in UTF-8, Docbook 5.1
I'm working on a Linux machine which has UTF-8 encoding. The docbook 5.1 I'm working with is declared:
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book [
<!ENTITY version "0.1 unreleased">
Entities changed a while back (relaxng changed things), but so far as I know I should still be able to work with numeric entities when using odd characters which are part of UTF-8. I'm trying to get some box drawing characters to work, specifically because I need to illustrate a file directory structure which has been output like this from the "tree -d" command. Here's a short sample:
> tree -d -L 2 /etc | tail -n 20 | tail -n 6
│   ├── pluginconf.d
│   ├── protected.d
│   └── vars
└── yum.repos.d
As you can see the vertical and horizontal box drawing characters are used. When I redirect this to a file or copy and paste into the document all I get is a substitute...each shows as "#". So I tried to use numeric entities instead. As an example "boxh" (horizontal box line) should work as "&#x2500;". This does not work, and rendering still ends up as "#". I tried the numeric code for the plus/minus character, "&#x00B1;", and this does work. I don't know if it proves anything, but since my UTF-8 terminal  shows all of the above characters just fine on a terminal, it seems like the ability to output is not in question...perhaps this is an invalid assumption.
Btw, one reference on the Unicode numeric value is from:
Under Docbook 5.1, what do I need to do to use this numeric entity other than using UTF-8 and the numeric entity syntax? Is there an additional XML declaration I need?

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]