OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Errors compiling XML files using latest DocBook on SUSE 9.2

Hello all. I've been using DocBook for about 6 months now and have
been watching this list closely. I've had success migrating much of my
work documentation to XML and DocBook.
Recently I upgraded to SUSE 9.2 Professional (got an advance copy from
Novell) and have been having issues compiling my XML files to HTML
using docbook2html.
All the necessary packages are installed. It's basically just like my
SUSE 9.1 setup which worked just fine.

I attempted to compile my XML documentation using the command
"docbook2html chap00.dns.xml". In the past under SUSE 9.1 (with minor
tweaking of the docbook-utils.dsl file) this generated all the HTML
files no problem.

SUSE 9.2 installs DocBook-4.3 as an upgrade. I have changed all
references in the primary file, chap00.dns.xml, to point to the latest
DocBook references; still no luck.
Here is the error I am getting:

# docbook2html chap00.dns.xml
Using catalogs: /usr/share/sgml/docbook/dsssl-stylesheets-1.78/common/catalog,
/usr/share/sgml/tei/teilite/catalog, /usr/share/sgml/openjade/catalog,
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.14/docbook-utils.dsl#html
Working on: /home/kjcox/documentation/dns/xml/chap00.dns.xml
jade:E: specification document does not have the DSSSL architecture as
a base architecture
jade:E: no style-specification or external-specification with ID

The text contents of all XML files referenced in the main file are
then printed to the screen.

This same error happens on upgraded versions of SUSE 9.2 as well as on
clean installs of SUSE 9.2 Pro. I've tried various XML files and the
error is the same. I have a ticket into Novell and SUSE on this but
have not heard anything yet.

The last two lines I assume are the clincher. I've googled for a
solution, but have had no luck. Perhaps something is foobar'ed with
the latest SUSE 9.2 Pro release and how they have implemented

Any suggestions would be appreciated. I'd like to get this fixed for
other SUSE users when 9.2 comes out.

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]