OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

entity-resolution message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: Re: first proposal

At 11:41 2000 11 29 -0800, Lauren Wood wrote:
>On 29 Nov 2000, Norman Walsh wrote:
>> Matter of taste, I guess. That means we have four choices:
>> 1. All UPPERCASE, as per 9401
>> 2. All lowercase
>> 3. camelCase like XML Schema, Java identifiers, etc.
>> 4. CamelCase like the SGML DocBook DTD (though only because case
>>    didn't matter)
>> I prefer 2 and 3 to 1 and 4.
>How about number 3, then, since I'd prefer 3 or 4. Other opinions?

I strongly prefer all lowercase.  Mixed case is just one extra thing
for users to get wrong (just which letters are what case?).  XHTML
decided on all lowercase, and I think we should too.

>> I wasn't suggesting "source" and "target" literally, just that we
>> pick consistent names for the left and right hand sides.
>> I'm not real thrilled with
>> <public publicid="-//OASIS//DTD DocBook XML V4.1.2//EN"
>>         href="/share/doctypes/docbook/xml/docbookx.dtd"/>
>No, I guess not. Any other suggestions?

externalid or extid.  that is what the left hand side is.
we are, after all, mapping external identifiers.

>> The "public" in publicid seems redundant and I'm not terribly pleased
>> with "href" either; this isn't a hypertext reference. Maybe the right
>> hand side should always be "uri"?
>OK by me.

well, of course I'd prefer soi, but realizing I'm not going to win that
one, I'd be okay with uri (though it's really a relative URI reference).

>> Looking forward, assuming we add some new specific keywords instead of
>> complete generality, what do we use as attribute names for
>> <stylesheet ... uri="..."/>
>> <namespaceName ... uri="..."/>
>> <schemaLocation ... uri="..."/>
>> Yep. I don't mind long names as long as they're clear. But I'm not
>> delighted with LoadCatalog, since it's the only one that's got a verb
>> in it.
>> Maybe just 'import'. (The semantics of the CATALOG directive are more
>> like xsl:import than xsl:include.)
>> Yes, I think I vote for 'import' all by itself.
>Works for me.

Please be sure you all understand the semantics of the TR9401 catalog
entry type before you go here.  Note that its semantics imply (logically)
"appending" the referenced catalog *at the end* of the current catalog.
This is not the usual behavior of "import", so I think we're asking for
problems using such a term.  If you want to match the semantics, perhaps
"nextcatalog" is best.


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC