OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

office-formula message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [office-formula] Functions that need to be identified as TBD

On Mon, 2006-11-09 at 18:10 -0400, David A. Wheeler wrote:
>    define functions without the "_ADD" with Excel semantics, and have "_OOO"
>    functions with the OOo semantics, e.g., "DURATION" vs. "DURATION_OOO".
>    The "_OOO" naming convention is lousy; 

I agree that it is lousy. I think we should choose the semantics that
make more sense to the regular one. If it is not the EL semantics we may
want to implement Excel's version as LEGACY...

If we think OOo's is just weird we should probably use another prefix
COMPATIBILITY... or so hoping that over the long term the more sensible
semantics takes over. 

> it's more
>    of a placeholder so that we can differentiate the functions.  Suggestions?
>    Many of these (GCD_ADD, ISEVEN_ADD, ISODD_ADD, LCM_ADD) are trivially
>    different - should these be implementation-defined (and NOT separate functions)?
>    Should these just be application-specific functions when exchanged?
>    We need to compare CONVERT_OOO and EUROCONVERT as well.
> * Consider adding EUROCONVERT (and compare to CONVERT_OOO).
>    Obviously it's still useful for long-term financial instruments, so I just need to know
>    if there's enough reason to include it in the spec itself.

Andreas J. Guelzow, Professor
Dept. of Mathematical & Computing Sciences
Concordia University College of Alberta

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]