[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: Re: [office-formula] Functions that need to be identified as TBD
Hi, On Friday, 2006-10-06 22:12:22 +0200, Eike Rathke wrote: > > * For CONVERT_ADD, CUMIPMT_ADD, CUMPRINC_ADD, DURATION_ADD, > > EFFECT_ADD, NOMINAL_ADD, GCD_ADD, ISEVEN_ADD, ISODD_ADD, LCM_ADD: > > define functions without the "_ADD" with Excel semantics, and have "_OOO" > > functions with the OOo semantics, e.g., "DURATION" vs. "DURATION_OOO". > > The "_OOO" naming convention is lousy; it's more > > of a placeholder so that we can differentiate the functions. Suggestions? > > I'd rather rename _ADD to _XL and keep the names without _ADD as they > are. Rethinking that, to be congruent with the other function names of the AddIn package, it might actually be better to have them all without _ADD and add an ORG.OPENOFFICE. prefix to the internal ones. Eike -- Automatic string conversions considered dangerous. They are the GOTO statements of spreadsheets. --Robert Weir on the OpenDocument formula subcommittee's list.