OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

office-formula message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [office-formula] Second DURATION needed

Eike Rathke:
> Currently we have a DURATION defined as
> DURATION( Number rate ; Number currentValue ; Number desiredValue )
> This probably because OOo for some legacy reason had implemented it for
> compatibility with whatever application. However, OOo also defines
> DURATION_ADD( Number Settlement ; Number Maturity ; Number Coupon ; Number Yield ; Number Frequency [ ; Integer Basis = 0 ] )
> which btw is also used to compute MDURATION. Gnumeric has DURATION with
> those 5+1 parameters and additionally has a function G_DURATION with
> 3 parameters same as OOo's DURATION.

Excel has 5+1 parameters too.

> I propose to rename the spec's current DURATION to LEGACY.DURATION and
> add DURATION with 5 parameters.

I agree with the rename and addition of the 5+1 parameter DURATION.  In the words of Capt. Picard, please "make it so"!

Instead of "LEGACY.DURATION", though, can we find a better name? SIMPLE_DURATION or some such?  Anybody have a suggestion?

--- David A. Wheeler

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]