OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

office-formula message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Summary of 2010-11-02 OpenFormula meeting

Summary of 2010-11-02 OpenFormula meeting

(As always, please reply-all with corrections.)

David A. Wheeler
Eric Patterson
Rob Weir
Andreas G.
Dennis Hamilton
Eike Rathke
Patrick D.


We started here and looked at unresolved issues:

* http://tools.oasis-open.org/issues/browse/OFFICE-2470

Wheeler: Eike made many improvements, but it revealed other issues, so I've posted a counter-proposal.

Had many discussions about fixing this.  We need to work to make it clearly match section 5.

Please post to JIRA any improvements.

* http://tools.oasis-open.org/issues/browse/OFFICE-3492

Wheeler: We shouldn't include multiple values; just include the exact one.

Eric: We should put down the authority, too.  We need the numbers AND the authority.

Wheeler: I'm concerned that some values may not be exact.

Eric: The implementor won't have any idea what values they should use.

Wheeler: So let's add the phrase "(exact)" and the source of the data?

Weir: "Some of the values below are not exact, but are accurate within the given number of digits.
More accurate values may be used as long as they are accurate within the given number of digits."

Wheeler: Okay.

{Check to make sure "accuracy" and "precision" are used correctly.}

Wheeler: I'll make a stab at this.

* http://tools.oasis-open.org/issues/browse/OFFICE-3042

Eric: I suggest removing the "USER." material.

Dennis: Is this the only place where "USER" appears?

Eric: Yes.

Eike: Which leads to a problem if a future function name has that name, it'll silently switch.
I still think we should save with the "USER." prefix.

Dennis: That'll *prevent* it from being recognized if it's a future function.
I think we should leave it.

Rob: I don't like this, because it's not really different than implementation-defined.

Dennis: "USER-defined" is a species on implementation.

Rob: We're not definining how to define functions, either.

Dennis: Get rid of USER.  Eric doesn't like it, and it doesn't really help interoperability
(as noted by Rob).

Eike: We should note that unknown functions shouldn't be produced.

Eric: No, we're then going backwards.

Rob: This is about conformance.  We can define what to do with a well-formed formula,
and a function we don't recognize is an Error.  Is there anything that prevents round-tripping
with unknown functions?  It should be *possible* for implementors to do that.

Eike: I think we should prefix user-defined functions.  We should state it somewhere, say in 5.7.1.

Wheeler: I don't like removing "USER.", but it looks like there's almost consensus for removing:
 5.7.2 User-Defined Functions
 Functions defined by users should include a "USER" prefix, followed by a period and the function name.

Rob: I'll add a note about user-defined functions.

Wheeler: Let's do that via JIRA today.

?: NOTE: this was marked as resolved, we need to make sure that changes to this actually get into the document.

{Never got to 3038.}

We will plan to meet next week, and cancel if it's not necessary.

--- David A. Wheeler 

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]