Subject: Proposal update: data cache, field name, source field id for data pilottables
Dear TC memebers,
I've updated this proposal:
The update contents include:
(1) Add comments in the table:field name user scenario that table:field-display-name seems more appropriate for the meaning, but current proposal uses table:field-name since it is already used in table:data-pilot-field-reference. But if anyone proposes to use a new name "table:field-display-name" and no one disagrees to that, I will totally agree. Of course, in case of that, the attribute <table:field-name> in the element <table:data-pilot-field-reference> should also be renamed to <table:field-display-name> since they have the same meaning. Till now, I know Kohei propose the new name, so I'm waiting for others' comments.
(2) Add a new user scenario for the data pilot table enhancement. That is to add an attribute <table:cell-auto-resize> to the <table:data-pilot-table> so that user can control whether or not the cells of data pilot table is resized automatically according to the height and width of cell contents when the data pilot table is refreshed.