[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: [OASIS Issue Tracker] Commented: (OFFICE-3451) Inappropriate use of"should"
[ http://tools.oasis-open.org/issues/browse/OFFICE-3451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=21730#action_21730 ] Dennis Hamilton commented on OFFICE-3451: ----------------------------------------- Michael, yes "evaluated for" is better. I am a bit uncomfortable with "evaluated" I would say "is applicable whenever ..." or maybe "is effective whenever ...". It seems that the attribute instance has to be resolved-to (according to inheritance on a specified style or by default) and it has to be applicable to the particular element instance. I don't think we should have to say that every time, but we need some definition of what we mean when we need to say a particular style attribute within a family is applicable to a given element. And "evaluated for" is better, but maybe not strong enough. I have no further thoughts at the moment. > Inappropriate use of "should" > ----------------------------- > > Key: OFFICE-3451 > URL: http://tools.oasis-open.org/issues/browse/OFFICE-3451 > Project: OASIS Open Document Format for Office Applications (OpenDocument) TC > Issue Type: Bug > Components: Needs Discussion, Part 1 (Schema), Styles > Affects Versions: ODF 1.2 CD 05 > Reporter: Andreas Guelzow > Assignee: Patrick Durusau > Fix For: ODF 1.2 CD 06 > > > In may places in the draft we have statements as: > " This attribute should be used within ... styles that are applied to a ... element. " > It may be more correct to say: > " This attribute may be used within ... styles that are applied to a ... element. " > or possibly > " This attribute may only be used within ... styles that are applied to a ... element. " -- This message is automatically generated by JIRA. - If you think it was sent incorrectly contact one of the administrators: http://tools.oasis-open.org/issues/secure/Administrators.jspa - For more information on JIRA, see: http://www.atlassian.com/software/jira