OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

pkcs11 message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [pkcs11] Proposal: Define CKA_JAVA_MIDP_SECURITY_DOMAIN constants

On 26.06.2013 19:13, Michael StJohns wrote:
> For this, I'm loath to let this look like the OTP stuff, as I think that
> was done in error.  Part of the idea of this PKCS11 API is to be able to
> project it onto other languages besides C and it would be useful if
> fields that were should actually be considered as enums (or a fixed set
> of values) were typed that way.  Unfortunately, all we can do is use
> appropriate naming conventions.

For what it's worth, the PKCS#11 API is hard to bind via the automatic
or semi-automatic tools as there is no simple namespace prefix for the
types and constants. So using all myriad prefixes is a strike against
projecting it into other languages using modern tools and techniques.
But I digress...

>> Should we just choose CKV_? That's the option that seems more broadly
>> acceptable. In that case, will you make a proposal to update the OTP
>> stuff?

Yeah, that's what I'd prefer.

> Sure I can't talk you into
> CKCM_ and CKCC_?

It's just that these really start to be unreadable.

> To table 2 we add "CKV_" "General enumerations"?  (Or alternately, we
> add these two prefixes.)

I like this, perhaps "Miscelaneous enumerations" or "Other enumerations"



[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]