OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

regrep-cc-review message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: Renaming "Data Types" (Was Re: [regrep-cc-review] [Further Consideration] Re: [regrep-cc-review] Help with clarifying registry handling of CCTS)

Chiusano Joseph wrote:
> Given the general confusion around the concept of Data Types, 
> I've been
> toying with the idea of renaming them for our Technical Note as "Core
> Component Type Restrictions" (CCTR), which is what they really are. I
> think that much of the confusion stems from the fact that folks
> (justified or not) think of a "Data Type" as a primitive type such as
> string, integer, etc. while our Data Types are much richer.

At first sight I don't like the idea, lets see if I can figure
out why. (I agree that CCTS names might be misleading.. there's
something wrong with DataType + CoreComponentType).

generically, data type sintatically defines and restricts the
content of a property/field. In our case, Data Type defines the
possible content for a BCC. It sounds strange to me to think of
a BCC being of type myCoreComponentTypeRestrictions. If I think
about it in Java (ignoring BIEs), this is what comes out:

public class MyACC {

 private myCoreComponentTypeRestrictions myBCC;


And it looks "funny", at least. :)

I wonder how they got to that name.. **speculating**:
BasicCoreComponent-Type?? No..
BasicBusinessInformation-Type??? Even worse..
RestrictedCoreComponentType?? No..
DataType?? mmm... quite generic but looks good. Let's use it.

After this short brainstorm with myself I'd say that
"Restricted Core Component Type" is still better than
"Core Component Type Restrictions". What do you think?


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]