OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

regrep message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [regrep] ebXML Registry Profile for Web Ontology Language - a few comments

Also, if "HasProperty" is used for rdf:Property should other
owl:XXXProperty be prefixed in the same way -> "Has"?

In this case, the use of "Has" as a prefix of property is already
somewhat misleading. Properties are first class entities in RDF/OWL.  

Comment was a question without taking a stance on validity of the choice
of "Has". However, it looks like properties in RDF/OWL semantically
express direction and question is whether it could be possible to
uniformly express this directional association using appropriate prefix
/ suffix. Interestingly enough, it looks like both OWL Web Ontology
Language Guide (http://www.w3.org/TR/owl-guide/) and OWL Web Ontology
Language Reference (http://www.w3.org/TR/owl-ref/) use "has" as a prefix
in several places, e.g., "hasWineDescriptor", "hasColor", "hasMaker",
"hasMother", "hasBankAccount", ...

I am not sure of the scope of the above suggestion.  The pattern
owl:XXXProperty seems to only apply to specializations of property such
as FunctionalProperty.  That would be tolerable if undesirable.
However, application of the "Has" prefix to subPropertyOf and subClassOf
would result in very confusing names indeed.  I would strongly object to
such names.

Scope of the suggestion was supposed to be deducible from the format
"owl:XXXProperty" -> it only applies to constructs like
owl:ObjectProperty, owl:DatatypeProperty, owl:TransitiveProperty, ...,
and not to constructs like rdfs:subPropertyOf and rdfs:subClassOf.


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]