OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

saml-dev message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: [saml-dev] openSAML build

 I've encountered a problem while building openSAML. I'm
using RedHat Linux 8.0 and have installed all the  required
packages in the 'INSTALL.txt' file of opensaml-0.7 (from
 the 'configure' script completes, but when i run the
'makefile' i get the following error:

source='XMLSignature.cpp' object='XMLSignature.lo' libtool=yes \
tmpdepfile='.deps/XMLSignature.TPlo' \
depmode=gcc3 /bin/sh ../depcomp \
/bin/sh ../libtool --mode=compile g++ -DHAVE_CONFIG_H -I.
-I/opt/shibboleth/include -I/opt/shibboleth/include/xmlsec
-I/opt/shibboleth/include/libxml2 -I.  -pthread -g -O2 -c -o
XMLSignature.lo `test -f 'XMLSignature.cpp' || echo
-DXMLSEC_NO_AES=1 -I/opt/shibboleth/include
-I/opt/shibboleth/include/libxml2 -I. -pthread -g -O2 -c
XMLSignature.cpp -MT XMLSignature.lo -MD -MP -MF
.deps/XMLSignature.TPlo  -fPIC -DPIC
XMLSignature.cpp:94: prototype for `void
const saml::Key&,
   const saml::Iterator<saml::X509Certificate*>&)' does not
match any in class
internal.h:125: candidate is: virtual void
const saml::Key&,
   const saml::Iterator<saml::X509Certificate*>&, bool = false)
XMLSignature.cpp:99: prototype for `void
   saml::XMLSignature::verify(_xmlSecKey*) const' does not
match any in class `
internal.h:126: candidate is: virtual void
   saml::XMLSignature::verify(_xmlSecKey* = 0, bool = false)
make[2]: *** [XMLSignature.lo] Error 1
make[2]: Leaving directory `/opt/shibboleth/opensaml-0.7/saml'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/shibboleth/opensaml-0.7'
make: *** [all] Error 2


Prior to this I encountered the following error for these
three files which I obtained from the opensaml/c directory

make: *** No rule to make target `libtool.m4', needed by
`aclocal.m4'.  Stop. 
(Obtained libtool.m4 Rev 1.1)

make: *** No rule to make target `acx_pthread.m4', needed by
`aclocal.m4'.  Stop. 
(Obtained libtool.m4 Rev 1.2)

make: *** No rule to make target `libtool.m4', needed by
`aclocal.m4'.  Stop. 
(Obtained libtool.m4 Rev 1.3)


I also copied 'internal.h' from the cvs into the
opensaml-0.7/saml directory as it was not present (for

Does anyone know how to resolve this problem? 

Also, is it better to use the opensaml.jar file? Can someone
tell me the cvs password?

Scott Cantor said that there's a list of SAML users called
'mace-opensaml-users'. unfortunately, i was given a message
saying that the list does not exist when i tried to
subscribe. Is there a similar list I can subscribe to?

Thanks in advance,


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC