Subject: Change draft for #90: fileLocation object
I pushed a change draft for Issue #90, which we agreed to in TC #9 (the face-to-face meeting).
Recall that the issue here is that there are several objects in the SARIF format which contain a pair of properties: a URI-valued property (usually but not always named uri) and a URI base id valued property (usually but not always called uriBaseId). The change is to package this frequently-occurring pair of properties into its own object, named fileLocation.
NOTE: The issue originally suggested that the new object be named “uriReference” but I think “fileLocation” is a better name. The new object is the location of a file; it is not a “reference to a URI”.
I have added this item to the Agenda that’s checked into the repo, and I will move for its adoption at the next TC meeting.
David, would you please add this item to the HTML version of the agenda, as:
4.2.9 Introduce fileLocation object [#90]