Subject: "algorithm" vs. "hash function"
After valuable feedback from Jim, I’m writing the spec text for Issue #107, “Settle on a small set of hash functions”. We’re going to suggest (but not require) that producers use hash functions that appear in the IANA registry of Hash Function Textual Names. That raises the point that IANA does refer to these things as “hash functions” rather than “algorithms” (although of course, the process of computing the function is specified by an algorithm).
While I’m in the process of editing this portion of the spec, what do you think of changing the property name hash.algorithm to hash.hashFunction, or hash.function, or hash.functionName?
I’m going to send the change draft while we consider this.