OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

sarif message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Cluster of logicalLocation-related changes

This morning at TC #18, we approved the change draft for Issue #143, “Add 'returnType', 'parameter' and 'variable' to logical location kind”, with two changes:


  1. localVariable => variable
  2. Change the statement that logical locations SHALL conform to language syntax to a SHOULD, and explain why.


It turns out that #2 is closely related to another issue that I was going to address editorially: Issue #170, “logicalLocation.name: text and examples are unclear/wrong”. It’s actually hard to do #2 without the cleanups I planned for Issue #170.


So here’s what I’m going to do:


  1. Rename the change draft from




  2. Address both the substantive issues #1 and #2 above, and the editorial issues for Issue #170, in that same change draft.

  3. Merge the changes from sarif-v2.0-issues-143-170-logicalLocations.docx into the provisional draft (because we’ve already voted to approve the substantive changes).

  4. Inform you when I’ve done that, so you can look at the change bars in the change draft.


I’ll follow up on this thread when I’ve done that. After that, feel free to comment on the wording of the substantive changes, or on the editorial changes. I’ll incorporate any such feedback at editorial discretion.






[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]