[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: RE: [sarif] Cluster of logicalLocation-related changes
This is now done. As I’ve done a few times before, I took a concept that occurred in a several places in the spec, and stated in in one place: the new Section 3.24.2, “Logical location naming rules”. All the other sections of the spec to which those rules apply (for example, the property names in the run.logicalLocations dictionary, and the values of location.fullyQualifiedLogicalName) now just refer to the new section.
I merged the changes into the provisional draft. To see the change bars, look at the change draft:
Again, feel free to suggest editorial improvements.
This morning at TC #18, we approved the change draft for Issue #143, “Add 'returnType', 'parameter' and 'variable' to logical location kind”, with two changes:
It turns out that #2 is closely related to another issue that I was going to address editorially: Issue #170, “logicalLocation.name: text and examples are unclear/wrong”. It’s actually hard to do #2 without the cleanups I planned for Issue #170.
So here’s what I’m going to do:
I’ll follow up on this thread when I’ve done that. After that, feel free to comment on the wording of the substantive changes, or on the editorial changes. I’ll incorporate any such feedback at editorial discretion.