OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

sarif message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [sarif] "generatedFile" => "uncontrolledFile"

The purpose of these roles is to help a SARIF consumer who can’t access a VCS to decide what files have changed (and so might need to be reanalyzed). Given that, I don’t see a useful distinction between a generated file and any other file that’s not under source control. In either case, the consumer either has to assume that the file has changed, or it has to keep track of a last-modified time, or a hash, of the file.


So I think generatedFile is not necessary as a separate property, and I propose we rename it to uncontrolledFile.


-----Original Message-----
From: sarif@lists.oasis-open.org <sarif@lists.oasis-open.org> On Behalf Of James A. Kupsch
Sent: Thursday, May 17, 2018 1:05 PM
To: sarif@lists.oasis-open.org
Subject: Re: [sarif] "generatedFile" => "uncontrolledFile"


It may be useful to have both of these.  generatedFile implies uncontrolledFile, but there are other referenced files that are uncontrolled, but not generated, such as files that are part of the standard library of the language.


If generatedFile is not useful, then uncontrolledFile is probably a better name.





On 05/17/2018 01:29 PM, Larry Golding (Comcast) wrote:

> For purposes of file.roles, generated files are interesting because

> they’re not under source control. There might be other files that are

> not under source control. Shall we rename "generatedFile" to

> "uncontrolledFile"? (Other name suggestions welcome.)


> Larry




To unsubscribe from this mail list, you must leave the OASIS TC that generates this mail.  Follow this link to all your TCs in OASIS at:



[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]