[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: RE: [sarif] Editorial change: codeFlowLocation => threadFlowLocation
I overstepped my editorial discretion here. This rename needs to be approved by the TC. I will put it on the agenda for TC #19.
There will not be a change draft since I’ve already made the change in the provisional draft. In the event that the TC rejects the change, I’ll revert it in the provisional draft.
This change is now in the provisional draft. Again, let me know of any concerns.
I have filed Issue #187: Editorial: codeFlowLocation => threadFlowLocation. Michael and I consider this an editorial change because it is a pure rename, with no change in semantics. Here is the description of the issue:
We will rename the
· The original name for this concept was
· In addition to being surprising, the name became just plain wrong when we moved annotations into the location object. Now every location could be annotated.
· The search for a new name came at the same time as we introduced the notion of an array of threads within a code flow. Michael and I struggled with whether to use
· Having decided to use
Please let me know if you have any concerns about this.