OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

sarif message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Change draft for #242: UTC property names

I pushed a change draft for Issue #242, “Rename startTime/endTime to startTimeUtc and endTimeUtc”:




We will move its adoption at TC #24 on Wednesday 9/26.


The motivation for the change is that a customer, not understanding that the spec required times to be UTC, erroneously set invocation.startTime to the local time. That caused a problem because the SARIF SDK automatically (and correctly) set invocation.endTime to a UTC time. Adding “-Utc” to the property names will mitigate this confusion.


While I was at it, I inventoried all the date/time property names and decided that there were two other issues:


  • We inconsistently used “time” in some names and “timestamp” in others.
  • We were not always sufficiently explicit about what the time(stamp) referred to.


So in summary, I propose the following renames:


  • invocation.startTime => startTimeUtc
  • invocation.endTime => endTimeUtc
  • file.lastModifiedTime => lastModifiedTimeUtc
  • versionControlDetails.timestamp => revisionTimeUtc (which, by the was is consistent with versionControlDetails.revisionId)
  • threadFlowLocation.timestamp => executionTimeUtc
  • notification.time => notification.timeUtc (“notification.notificationTimeUtc” seemed unnecessarily redundant but I’m willing to be persuaded on that point)




[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]