OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

sarif message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: 'externalFiles' to 'externalFragments'?

By the way, Michael and I were having this discussion in the context of working to close the existing Issue #118, “SARIF file naming convention”. We are not proposing to open a new issue. It we did decide (for example) to rename externalFiles to externalFragments, we would do it in the context of #118.


Hey! Why not name it (“it” being the thing we today call a “externalFile”) sarifFragment rather than externalFragment? That is parallel to the existing sarifLog type! And it would then map most naturally to the filename extension “sarif-fragment”.




From: sarif@lists.oasis-open.org <sarif@lists.oasis-open.org> On Behalf Of Larry Golding (Myriad Consulting Inc)
Sent: Wednesday, October 17, 2018 10:02 AM
To: Michael Fanning <Michael.Fanning@microsoft.com>; 'OASIS SARIF TC Discussion List' <sarif@lists.oasis-open.org>
Subject: [sarif] RE: 'externalFiles' to 'externalFragments'?


“sarif-fragment” is nice because it suggests “sarif-resources” as the extension for the language-specific resource files defined elsewhere in the spec. If “-sarif” is at the end of the extension, you end up with “resources-sarif” which doesn’t read as well.


From: sarif@lists.oasis-open.org <sarif@lists.oasis-open.org> On Behalf Of Michael Fanning
Sent: Wednesday, October 17, 2018 7:31 AM
To: 'OASIS SARIF TC Discussion List' <sarif@lists.oasis-open.org>
Subject: [sarif] 'externalFiles' to 'externalFragments'?


Larry and I were discussing a possible rename yesterday, just sanity checking this with the group. We were specifically noting that we require a naming convention to help distinguish ‘external’ files. The reason is that their only distinguishing characteristic within the file is the $scheme property, which is optional (the version property matches a root/parent SARIF file).


And so a convention to name these files something like *.external.sarif would be useful. Alternately, of course, we could consider defining an entirely new extension, e.g., external-sarif.


When considering either a new extension or a file naming convention, it occurred to me that the use of the term ‘fragment’ would be clearer. And so I have two questions:


  1. What would people think about using ‘externalFragments’ as a name rather than ‘externalFiles’? This would be minimally intrusive in the spec and lead to file names such as ‘example.fragment.sarif’, which is clearer than ‘example.external.sarif’.
  2. What mechanism should we prefer, a naming convention or a new extension? I,.e., ‘example.fragment.sarif’ or ‘example.fragment-sarif’? or even ‘example.sarif-fragment’ (which is entirely readable)



[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]