OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

tosca message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: [OASIS Issue Tracker] (TOSCA-229) Requirements / target filters and subsituable / selectable are too confusing.

    [ https://issues.oasis-open.org/browse/TOSCA-229?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=59191#comment-59191 ] 

Chris Lauwers commented on TOSCA-229:

I agree with Matt. I think there sometimes is value in supporting different mechanisms to express the same thing, since each mechanism may be more convenient than the others for different use cases.

That said, I believe it might be possible to avoid confusion by making the grammar for these mechanisms more similar. Specifically, I would argue the following:

1. target_filter should be renamed to node_filter to reflect what it actually does (in fact, the supporting prose in the document already refers to target_filter as node filters)
2. in a requirement assignment, I would like to see target_filter/node_filter be a sub-keyname of the node keyname (rather than a top-level keyname in the requirement assignment) since that would make the grammar for nodes in a requirement assignment (almost) identical to the grammar for selectable node templates.

I would love to understand better how we can further harmonize selectable and substitutable node templates

> Requirements / target filters and subsituable / selectable are too confusing.
> -----------------------------------------------------------------------------
>                 Key: TOSCA-229
>                 URL: https://issues.oasis-open.org/browse/TOSCA-229
>             Project: OASIS Topology and Orchestration Specification for Cloud Applications (TOSCA) TC
>          Issue Type: Improvement
>          Components: Profile-YAML, Spec - Simple Profile
>            Reporter: Luc Boutier
> There is too many notions in the requirements management in the current simple profile document. This makes things very hard to follow while there is actually in my opinion not that many notions to be defined.
> Target filter makes no sense in my opinion in their current placement (on the node template requirements) as they are duplicated with the selectable directive.
> I think it would be more consistent to use the 'selectable' directive in every situations rather than relying on target_filter.
> I also think that selectable pattern is also exactly the same as substitutable from a user perspective as this answer a single need:
>  - I want to link some components to a node that is abstract and I rely on the orchestrator tool to provide a node that match my requirement.
> The fact that the orchestrator provides a selectable or automatic (substitutable) matching (or both with a best-match) is a tool feature and has no place in the specification in my opinion. The matching and quality of matching feature and presentation of the feature is implementor specific.

This message was sent by Atlassian JIRA

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]