OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

uddi-spec message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [uddi-spec] Update to CR010 for identifier definition

Title: Message
Your interpretation is still correct: isReplacedBy points from the "old" entity to the "new" one. I did not suggest to add even another tModel that does the same vice versa.
What I suggested is that we grandfather the categorization of isReplacedBy although we now know better (it should be a category system). If we decide otherwise, i.e. saying that it is correctly categorized as an identifier system, we are running into other problems, including the categorization of the owningBusiness tModel, which is then wrong (it IS a category system but SHOULD then also be an identifier system).
-----Original Message-----
From: Rogers, Tony [mailto:Tony.Rogers@ca.com]
Sent: Donnerstag, 6. März 2003 01:14
To: Von Riegen, Claus; Andrew Hately; uddi-spec@lists.oasis-open.org
Subject: RE: [uddi-spec] Update to CR010 for identifier definition

Actually, it suggests that we should have a tModel called, perhaps, "Replaces" - this would be put on a new tModel to identify it as one which replaces an old tModel, and give the old tModel's key as its value.
This assumes that I haven't misunderstood "isReplacedBy" - if it is intended to label the new tModel with the key of the old one it replaces, then I have to say that the name is confusing. "isReplacedBy" sounds like it is added to the old tModel, specifying the key of the new tModel that this old one isReplacedBy.
Either way, I have no problem with this being an identifier (now that we have the cardinality resolved), because we're identifying one tModel in terms of another one to which it is related by way of replacement.
Tony Rogers
-----Original Message-----
From: Von Riegen, Claus [mailto:claus.von.riegen@sap.com]
Sent: Wednesday, 5 March 2003 23:54
To: 'Andrew Hately'; uddi-spec@lists.oasis-open.org
Subject: RE: [uddi-spec] Update to CR010 for identifier definition

Thanks, I very much like the new glossary definitions. They certainly clarifies UDDI's meaning of identifiers and categories.
Although I clearly don't want to restart the whole discussion again, the new definition still does not allow isReplacedBy to be an identifier system.
Since the core definition of an identifier system remains the same as "Any value set intended to be used to identify the entities in which it is referenced.", there is strictly speaking no possibility for an entity to be identified with another entity's identifier. In other words, it is not the question whether a value from a given value set can represent an identifier or not, it is a question in which context and to which type of entity it is applied to (this is part of the corresponding value set's definition).
Taking the isReplacedBy example, we have an entity X and a separate entity X1, which logically replaces X. The entity key of X1 can certainly be used to identify X1 since it is actually X1's unique identifier within the given registry. But when X1's key is referenced in entity X, it still idenfies X1 - and not X. This is the question of the context I mentioned above: one can certainly use entities' identifiers and reference them in another entity, but this reference would be placed in a categoryBag rather than in an identifierBag.
Please note that I can live with the current situation, that is, grandfathering the isReplacedBy tModel's categorization as an identifier system, although we now know better. Another option would be to relax the glossary definitions even further by saying, for example, "Any value set intended to be used to identify entities [Ed. note: X1 from the example] in entities [Ed. note: X from the example] in which it is referenced." But my gut feeling is that this somehow even complicates the interpretation - and we would also have to update the sections where identifierBag and categoryBag are introduced in chapter 3.
-----Original Message-----
From: Andrew Hately [mailto:hately@us.ibm.com]
Sent: Dienstag, 4. März 2003 22:45
To: uddi-spec@lists.oasis-open.org
Subject: [uddi-spec] Update to CR010 for identifier definition

Please review the attached update.

Andrew Hately
IBM Austin
UDDI Development, Emerging Technologies
Lotus Notes: Andrew Hately/Austin/IBM@IBMUS
Internet: hately@us.ibm.com
(512) 838-2866,  t/l 678-2866

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]