OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

virtio-dev message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [virtio] [RFC PATCH 1/3] notifications: unify notifications wording in core

On Wed, Apr 11, 2018 at 12:11:25AM +0200, Halil Pasic wrote:
> Let us unify the wording when talking about notifications. This change
> establishes the terms available buffer notification for what was usually
> simply called notification or virtqueue notification in v1.0 and used
> buffer notification for what was usually called interrupt.
> The term configuration change notification in kept where called so and
> consolidated where it's called configuration change interrupt or
> similar.
> The changes done here are limited to the core part, and don't
> conceptually involve neither the transports nor the devices (references
> are updated though). Future changes should address these parts.

Nice, I think the cleanup is worthwhile.

>  \begin{lstlisting}
> -virtq_disable_interrupts(vq);
> +virtq_disable_notifications(vq);

This name is ambiguous.  Only used buffer notifications are disabled,
not configuration change notifications.

How about:


Attachment: signature.asc
Description: PGP signature

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]