OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

wsbpel message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: Re: [wsbpel] A minor enhancement proposal


Remember the name for activities is optional, too. Then, there's no good
reason that other constructs like <onEvent>, <onAlarm>, <copy> and so on
should not have a name, too. The only good reason I can think about that
these constructs does not need a name is they can be uniquely identified by
the position, i.e. <onMessage> element '3' in pick activity 'Pick'.

Best regards,

       Thomas Schulze

             Ron Ten-Hove                                                  
             Sun.COM>                                                   To 
             Sent by:                  wsbpel@lists.oasis-open.org         
             Ronald.Ten-Hove@S                                          cc 
                                       [wsbpel] A minor enhancement        
             03.05.2006 15:06          proposal                            


    I'd like to suggest a minor improvement to WS-BPEL, to help make it
more consistent, and a better language for users & tool developers:

    Add a "name" attribute to <onMessage>.

    All of the other major "nodes" in a BPEL graph have names, which
make them "self documenting" in a very natural way. This also helps make
graphic depictions of a process graph more readable.

    I can't think of a good reason <onMessage> should not have a name. I
also can't think of how introducing this change (at the last minute,
admittedly) would be at all risky. Should I open an issue on this?


To unsubscribe from this mail list, you must leave the OASIS TC that
generates this mail.  You may a link to this group and all your TCs in

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]