OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

wsrp-wsia message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: Re: [wsrp-wsia] v0.90, comments and questions

Hi Rich,

I'm missing request #35, did you send it around?
Nevertheless here are my comments on #35:

I would agree that we should change it to name=value.
I see no real advantage in have it the way it is today.
However this would have impacts on differnt document sections.
We need to define a parameter name which MUST be present in the parameters
field like wsrp-urlType={wsrp-urlType} (add wording).
Second the BNF syntax changes (10.2.3).
Third we should change the producer URL writing example in 10.2.2.

Mit freundlichen Gruessen / best regards,

        Richard Jacob
IBM Lab Boeblingen, Germany
Dept.8288, WebSphere Portal Server Development
Phone: ++49 7031 16-3469  -  Fax: ++49 7031 16-4888
Email: mailto:richard.jacob@de.ibm.com

|         |           Rich             |
|         |           Thompson/Watson/I|
|         |           BM@IBMUS         |
|         |                            |
|         |           01/23/2003 03:16 |
|         |           PM               |
  |                                                                                                                                                  |
  |       To:       wsrp-wsia <wsrp-wsia@lists.oasis-open.org>                                                                                       |
  |       cc:                                                                                                                                        |
  |       Subject:  Re: [wsrp-wsia] v0.90, comments and questions                                                                                    |

intertwined with <rt/>

Rich Thompson

Alejandro Abdelnur <alejandro.abdelnur@sun.com>
01/23/2003 03:58 AM

        To:     wsrp-wsia <wsrp-wsia@lists.oasis-open.org>
        Subject:        [wsrp-wsia] v0.90, comments and questions

Hi everybody, I?e made it back.
<rt>Good to have you back! Hope it was a great vacation.</rt>

First of all, great job with v0.90. The flow of the specification is
very easy to follow, concepts are explained in a very clear and simple

Following some comments and feedback on it. Some of my comments may have
been already addressed (I did not have time to catch up with all the
email discussions yet).



1- P10/L3
Consumer Configured Portlet it seems a misleading name, I would
suggest something denoting that are consumer created entities instead.
<rt>Suggestions welcome ... open change request = #4</rt>

2- P10/L19-23
Should we add something like Although this does not imply that the
portlet should not validate the End-User input.
<rt>added change request #28</rt>

3- P14/L27
Instead this functionality I would explicitly mention bookmarking
functionality. At first it gave me the impression it was referring to
navigational state.
<rt>added change request #29</rt>

4- P16/L29-P17/L9
It appears to me that these two sections are about the same thing.
Wouldn? make sense to merge them in one section
<rt>added change request #30</rt>

5- P20/L1-3
I need somebody to refresh my memory. When did we agree on 255 as a
maximum handle length?
<rt>Nov. F2F</rt>

6- P20/L38-P21/L19
Where and what for are we using Resource and ResourceList types?
<rt>They are the structures used to carry string values for other

7- P22/L1
MarkupType name for this type is misleading.
<rt>I've started to rename it several times, but never came up with a
better name ... need a suggestion and then I'll open a change request</rt>

8- P22/L19
The portlet description should a ModelDescription element, shouldn? it?
<rt>We had decided not to automatically include this in the
PortletDescription (issue #120)</rt>

9- P23/L27-42
If the userContext or the templates are stored in the session and the
change within the span of a session, they should be resent, right? If
so, we should clarify so.
<rt>added change request #31</rt>

10- P24/L19-23
Is this section saying that the value is always and array, and it could
be of generic objects or just string? I assume so, but it is not clear
to me.
<rt>It is trying to say that in general it is an array of objects. Since
we expect it to frequently be a single string, an alternate form for
passing this simpler type is provided.</rt>

11- P25/L24
ModelDescription does not convey the meaning of this type, I would
suggest something like PropertiesDescription.
<rt>It is used to describe the model of something. Current two uses are
Producer-specific registration data and Portlet-specific properties.

12- P27/L27
What is the purpose of the RegistrationState ?
<rt>It is a RegistrationContext without the handle ... suggestions for a
better name?</rt>

13- P36/L4-11
What kind of escaping?
<rt>added change request #32</rt>

14- P36/L12-16
What is the purpose of markupBinary ?
<rt>Carrying markup types that do not map into a string field. Examples
include an image and a DIME attachment (using currently proposed

15- P38/L10-15/L29-30
SessionContext, portletContext and markupContext elements are missing
from the UpdateResponse IDL description.
<rt>They are encapsulated in the interactionResponse field ... decision
was to use this format to clarify that blocking interactions return
everything from the non-blocking case. adding change request to delete
textual part that was missed (#33).</rt>

16- P40/L15
What is the behavior en the cache has expired, the consumer sends the
validateTag to the producer and the producer says it? OK? Is a new
expiration sent with the response? It should, right?
<rt>added change request #34</rt>

17- P40/L26-33
In the case of a allUsers?cache, the expiration mechanism is not
clear. It says that if the MarkupParameter change the cache must be
invalidated. Which one? How different locales are handled? Different
markups?, etc ?
<rt>I read this to say that the markup may be cached and supplied to all
users who would be using the same MarkupParameters. MarkupParameters does
include locale, markupType, etc.</rt>

18- P42
Not that I fully agree with this (email to follow), but if this is the
behavior we should explicitly mention that properties cannot be changed
in the getMarkup call. I know that because of the method signature it is
not possible, but as a clarification to the reader.
<rt>I presume you mean portletState can not be changed in getMarkup(). I
would note that this is in the section dealing with Interaction Operations
(i.e. 6.3).</rt>

19- P44/L1-15

I don? agree with the recommendation on not swapping from non-secure to
secure and vice versa. There are app servers and web servers that
support this. The Servlet spec allows implementations to support this.
Also, if we do not recommend this swapping, why do we provide the secure
url-templates when we are insecure and vice versa?
<rt>secure to non-secure would be a security violation. The non-secure to
secure is guidance ... if the Consumer "knows" it will work for the
Producer, this direction of movement is less problematic.</rt>

20- P48/L17-19
How is solo different from maximized? I mea, practically, what would the
consumer or producer do differently?
<rt>Examples raised included other portlets appearing minimized in
maximized windowState vs not appearing in solo windowState.</rt>

21- P49/L16-17
What does it mean the last sentence?
<rt>If the Portlet requires a userCategory to work properly, the Producer
should provide a default for when the Consumer does not supply one.</rt>

22- P49/L22-31
I think I understood the reason behind changing roles for user
categories, not to imply a security related classification. But
Administrator and User, they are security related classification.
<rt>see change request #5</rt>

23- P49/L32-24
How is different from a request with no user categories when both
consumer and producer support them? I thing the Guest user category is
<rt>Do bring this up in the discussion about change request #5.</rt>

24- P60/L25-42
Could we change the wsrp-urlType syntax so it is name=value as all the
other parameters? This would allow implementations that handle the type
as a parameter not to have to parse the parameter string.
<rt>added change request #35</rt>

25- P65/L7-23
What is the purpose of the interaction parameters being generic to a
producer? I don? get it.
<rt>Makes it simpler for some Consumers.</rt>

To subscribe or unsubscribe from this elist use the subscription
manager: <http://lists.oasis-open.org/ob/adm.pl>

To subscribe or unsubscribe from this elist use the subscription
manager: <http://lists.oasis-open.org/ob/adm.pl>

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC