Subject: Re: Shorthand notation in JSON profile and unmarshalling
Hi,The consensus on the list is to be consistent. Therefore the subject category should be called "access-subject" in JSON.However, there is one drawback, and it's not specific to subject. Any key that uses a hyphen or whitespace or other special characters (:,;...) is not user-friendly.This means that it might be better to take another approach to shorthand naming. For instance CamelCase:access-subject would become accessSubject.The reason is that in languages that automatically unmarshall JSON into objects won't be able to use the property name as a means to access the value e.g.request.access-subject will not work for obvious reasons. The proper way is to do request["access-subject"].request.accessSubject would though.These are the values that would need a CamelCase version:
requesting-machineThoughts? Put up with request["access-subject"]? Change the shorthand naming convention?Thanks,David.