OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

xliff message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]

Subject: RE: [xliff] R37: Revised Validations Module proposal

Hi Ryan, all,

Some feedback on the Validation proposal (nothing major, just possible suggestions):

-- strbegins and strEnds attributes:

Maybe names such as startsWith and endsWith may be a bit more descriptive of the function?

-- dblSpace:

This seems to be a very specific check. Maybe it can be generalized a bit without making it very different? For example, instead of dblSpace="3" we could do occurrence="  |3" (or a better name than 'occurrence'). This would allow to check for more than double spaces.

-- mustLoc:

How do you represent the '|' if it needs to be in the left part of the value?

-- existsInSource, disabled:

So far I think XLIFF is using yes|no for Boolean rather than true|false. Maybe we could be consistent?


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]