OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.

 


Help: OASIS Mailing Lists Help | MarkMail Help

cgmo-webcgm message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]


Subject: Re[2]: [cgmo-webcgm] Re: The highlight() method


I also lean towards, some flavor of Option 4.  Mostly, because I think it 
is least disruptive -- it adds a "convenience method" that all 
implementations must have, but all existing scripts remain valid.  To me, 
it seems least disruption for the user, and the least technical change to 
the CS spec.

Additional comments in-line...

At 03:39 PM 12/9/2005 -0500, Benoit Bezaire wrote:
>Hi Stuart,
>
>Please see inline...
>
>Friday, December 9, 2005, 1:20:23 PM, you wrote:
>
> > Hello,
>
> > I think that the ability to apply a highlight to a single item is an
> > important feature to have.
>Ok. Enough to hold the spec a bit longer and make more modifications
>to fix the problem? (just asking)

I'm curious what you mean by "hold the spec a bit longer"?  Committee 
Specification is finished and published.  The next chance for making such a 
technical change is either:
a.) in W3C, if the project is accepted and goes forward (then it will come 
back to OASIS);
b.) or in a new CS cycle here, if there is no W3C project.


> > My first thought was to overload the argument list, but that is not
> > allowed by ecmascript (or javascript).
>Same here, but as you said, that's not an option (too bad).
>
> > So my thoughts turned to something along the lines of option 4. Can
> > I either create a list on the fly or can I dereference an existing
> > list?
>Dereferencing the list I don't think is technically possible. You
>would instead need a 'for' loop and call highlight with each item, but
>them you run into timing issues. Create a list on the fly makes more
>sense in my opinion.
>
> > creation on the fly would require something like:
> > var aps = pic.getAppStructureById("apsToHighlight");
> > pic.highlight(aps.makeNodeList(), true);
>Exactly.
>
> > and dereferencing the list would look something like:
> > var list = pic.getAppStructuresByName("listToHighlight");
> > pic.highlight( list.items(), true );
>As I said above, I don't think it's doable without a 'for' loop.
>
> > I think that the dereference option would work because you can
> > have a variable number of arguments in a function.
>No, see above (or at least, I don't know how to do that).
>
> > Either one of these would require changes to support.
>That's correct.
>
> > I think that the first has the advantage that all the existing
> > scripts would continue to work...
>True.
>
> > I am not sure that I understand the problem of the live node
> > view of the DOM.
>Forget I said that for now... that's an implementation hurdle.
>Although they are important, let's look at it from a user perspective
>for now.
>
> > A kludge workaround would be to be get the object by id and then
> > get a list of objects that share the same name.  You then iterate
> > through the list removing items that do not have the id that you
> > want... (Ugly but can be done)
>:-) Ugly as you said. That's what users would have to do if we leave
>the spec like it is.
>
> > I cannot speak to which version of the spec highlighting should
> > be fixed.
>What do you think of the option of having two highlight method (ex:
>highlightOne (takes a single APS), highlightMany (takes a list of
>APS)?

Unless highlightMany is actually the current "highlight()", in name and 
syntax, I definitely prefer option 4.  I.e., changing the name from 
highlight() to highlightMany is somewhat gratuitous and unnecessarily 
disruptive (current scripts stop working).

Otherwise, I'm not sure if there's much substance to choose between Option 
4 and "highlight() plus highlightOne()".  In either case, you're adding the 
convenient capability to highlight one, and making an additional required 
method for every implementation.

Regards,
-Lofton.


> > -----Original Message-----
> > From: Benoit Bezaire [mailto:benoit@itedo.com]
> > Sent: Friday, December 09, 2005 7:42 AM
> > To: cgmo-webcgm@lists.oasis-open.org
> > Subject: [cgmo-webcgm] Re: The highlight() method
>
> > I haven't heard from anyone regarding this one either? Your comments
> > would be appreciated.




[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]