OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

docbook-apps message

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Subject: Re: DOCBOOK-APPS: attribute sets

In response to my

> Okay, I guess I don't get it. How do I make use of the attribute-sets in
> customization layer? I tried this:
> <xsl:attribute-set name="admonition.title.properties">
>    <xsl:attribute name="font-size">10pt</xsl:attribute>
>    <xsl:attribute name="font-weight">bold</xsl:attribute>
>    <xsl:attribute name="hyphenate">false</xsl:attribute>
>    <xsl:attribute name
> ="keep-with-next.within-column">always</xsl:attribute>
> </xsl:attribute-set>
> And it did nothing. If I make the font-size change directly to the
> param.xsl file, that works. All my param settings work, but the
> attribute-sets don't. Am I missing an important step?
> DocBook XSL 1.55.0
> xsltproc (libxml2 2-4-24/libxslt 1.0.20)
> PassiveTeX 1.21

Bob said:

I know you hate it when someone says this, but
"it worked for me".  I got 10pt "Note" text in my fo output.
I didn't run it through an FO processor, though.
Check your FO output.

What is supposed to happen is that attribute sets of
the same name are merged.  Attributes
with the same name in the set use import precedence
to select the value.  Your customization layer has higher
import precedence, so it should work.  Since you only
want to change the font-size, you should be able to
just specify that and it will get merged with the others.

<xsl:attribute-set name="admonition.title.properties">
   <xsl:attribute name="font-size">10pt</xsl:attribute>

But your version should have worked as well,
so something else is going on.

Nope. Tried the shorter version of the attribute-set and processed only to
FO. No go. Every param works, all my custom templates work, but the
attribute-sets are just ignored. I even finished upgrading to 1.56.1. No
difference. If I make the changes directly in the param.xsl file, they
process. Nothing I put in an attribute-set in my customization layer does
anything (my list.block.spacing doesn't work, either).

Could this be an xsltproc problem?

I've attached a copy of my customization layer. Have I unknowingly included
something that says disregard all attribute-sets?

(See attached file: ldoc-fo.xsl)

Dennis Grace

Information Developer
IBM Linux Technology Center
(512) 838-3937  T/L 678-3937  cell: (512)-296-7830

There are only 10 kinds of people in the world: those who understand binary
and those who don't.

                      Bob Stayton                                                                                                      
                      <bobs@caldera.com        To:       Dennis Grace/Austin/IBM@IBMUS, docbook-apps@lists.oasis-open.org              
                      >                        cc:                                                                                     
                      Sent by:                 Subject:  Re: DOCBOOK-APPS: attribute sets                                              
                      10/09/2002 05:40                                                                                                 


Bob Stayton                                 400 Encinal Street
Publications Architect                      Santa Cruz, CA  95060
Technical Publications                      voice: (831) 427-7796
Caldera International, Inc.                 fax:   (831) 429-1887
                                            email: bobs@caldera.com

Attachment: ldoc-fo.xsl
Description: Binary data

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [Elist Home]

Powered by eList eXpress LLC